Indexing is failing, targeting wrong DB?

Tim's Avatar

Tim

24 Jan, 2011 09:52 AM

Just uploaded some data to my db and tried to index but FS is trying to connect to a db on localhost? The FS log states:

ERROR: index 'sample_core': sql_connect: could not connect to server: Connection refused

Is the server running on host "127.0.0.1" and accepting
TCP/IP connections on port 10320?
  1. Support Staff 1 Posted by Pat Allan on 24 Jan, 2011 10:00 AM

    Pat Allan's Avatar

    Hi Tim

    The way FS is setup, it's using port forwarding to get to the database (no other way I'm afraid), so localhost is correct.

    You're not the first to have hit this issue - there's a fix in Github, so can you try using the repo as the source in your Gemfile?

    gem 'flying-sphinx',
      :git    => 'git://github.com/flying-sphinx/flying-sphinx.git',
      :branch => 'master'
    

    I'll get a new gem released pushed soon (would be good to confirm this fix works for you as well first, though :)

  2. 2 Posted by Tim on 24 Jan, 2011 10:20 AM

    Tim's Avatar

    That did the trick :)

    I'll knock up a quick ui and you can have a look.

  3. Pat Allan closed this discussion on 24 Jan, 2011 10:24 AM.

  4. Pat Allan re-opened this discussion on 24 Jan, 2011 10:57 AM

  5. Support Staff 3 Posted by Pat Allan on 24 Jan, 2011 10:57 AM

    Pat Allan's Avatar

    For anyone else who wanders across this discussion - 0.4.1 is the newly released version of Flying Sphinx that fixed this problem.

  6. Pat Allan closed this discussion on 24 Jan, 2011 10:57 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac