No erros, but search is not working on Heroku

jevin9's Avatar


16 Nov, 2015 07:28 PM


I've been trying to get Sphinx to run on Heroku since a few days to no avail.
heroku run bundle exec flying-sphinx configure gives no error messages heroku run bundle exec flying-sphinx index runs perfectly fine heroku run bundle exec flying-sphinx start runs fine too

Here is my current stack:
Heroku (
Sharetribe CMS (Ruby 2.1.2 & Rails 3.2.21)
thinking-sphinx 3.1.3
flying-sphinx 1.2.0

Let me know if you guys need more info from me. Thanks in advance for any help!

  1. Support Staff 1 Posted by Pat Allan on 16 Nov, 2015 11:18 PM

    Pat Allan's Avatar

    Hi Jevin

    Indexing is running, but it's raising errors (which should be visible when you run it) because ClearDB uses SSL for the database connections, and you'll need to configure your Sphinx installation with that certificate too.

    The relevant Sphinx settings for MySQL and SSL are listed here:

    If you set these in config/thinking_sphinx.yml for the correct environment (each refer to a file), and then deploy that change with the appropriate files (which will need to be within your repo, referred to via relative paths from your project root), the next time you run rebuild or configure, those settings will be pushed up to the Flying Sphinx servers, and indexing should work after that.

    If anything's not clear with this, or a new issue appears, do let me know.

    Kind regards,


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac