Extended matching mode does not seem to be working

Duncan Brown's Avatar

Duncan Brown

01 Sep, 2016 12:52 PM

Thanks for a great product.

I cannot seem to be able to use any of the extended query syntax (http://sphinxsearch.com/docs/current.html#extended-syntax) either on FS or on TS locally. The TS docs (http://freelancing-gods.com/thinking-sphinx/searching.html#matchmodes) say that v3 and up always use the extended mode, but when I try, for example, the phrase "George Washington", I receive separated instances of 'George' and 'Washington' as well as the phrase itself. Other matchers, like MAYBE, also fail to register as operators and show up in search results. Am I missing a configuration step?

  1. Support Staff 1 Posted by Pat Allan on 02 Sep, 2016 06:45 AM

    Pat Allan's Avatar

    Hi Duncan,

    There's no configuration step required - extended match mode should just work. Just to confirm: is your search for "George Washington" including the quotes? Or is it just a string with two words separated by a space? The former is the right approach for phrase matches! (I'm guessing you're across that already, but just want to make sure.)

    Is the quoted phrase the only thing in your search query? Or are there other elements as well that may influence matches?

    Regards,

    Pat

  2. 2 Posted by Duncan Brown on 02 Sep, 2016 10:32 AM

    Duncan Brown's Avatar

    Hi Pat,

    Thank you for your swift reply.

    I think this was a mistake on my part! I think my issue is with the excerpter: if I search for "George Washington" (quotes) I get the full match, but I also see partial matches ('George' and 'Washington') in the excerpt. Glancing at the Sphinx docs suggests I should enable "query_mode" on the excerpter. Will give that a go.

    Happy FS subscriber—thanks for the software.

    Duncan

  3. Support Staff 3 Posted by Pat Allan on 05 Sep, 2016 02:28 AM

    Pat Allan's Avatar

    Heya Duncan,

    Great to hear things are mostly working well for you! And certainly, if the excerpting is still not behaving quite how you’re wanting, do let me know.

    Cheers


    Pat

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac