Cannot get FS working

Todd's Avatar

Todd

24 Apr, 2018 09:14 PM

I just set up the FS addon.

When I tried to `heroku run rake ts:index` I got `ThinkingSphinx::ConnectionError: Error connecting to Sphinx via the MySQL protocol. Lost connection to My
SQL server at 'reading authorization packet'`. Reading some of the discussions here I tried `heroku run flying-sphinx start` and got `Action timed out. If this is happening regularly, please contact Flying Sphinx support: http://support.flying-sphinx.com`

I have tried these each a few times.

I am a little stuck. Please advise.

  1. Support Staff 1 Posted by Pat Allan on 24 Apr, 2018 11:44 PM

    Pat Allan's Avatar

    Hi Todd,

    Sorry to hear things haven’t been working for you. Can you let me know what the name of your Heroku app is, and also which versions of the thinking-sphinx and flying-sphinx gems you’re using? That’ll help me debug further.

    Kind regards,


    Pat

  2. 2 Posted by Todd on 25 Apr, 2018 05:58 PM

    Todd's Avatar

    Things seem to me working for me now. The 'View Log' links in the Dashboard yesterday was coming up blank for some reason, but today I am see I missed the configure step so my bad.

    Thank you for your response!

    Todd

  3. Support Staff 3 Posted by Pat Allan on 26 Apr, 2018 04:12 AM

    Pat Allan's Avatar

    Ah, that was due to a fix I made yesterday - I’d noticed the errors, glad the information’s now getting through and the logs are useful :)

    Do get in touch if anything else isn’t working as expected!

    Cheers,


    Pat

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac