net-ssh version dependency conflicts

Rob's Avatar

Rob

24 May, 2011 05:23 AM

Hi there,

I am using CarrierWave with Fog which depends on net-ssh 2.1.4. However, you are using an older version 2.0.23 which is keeping me from being able to use FlyingSphinx. Is it possible for you to use the latest version of net-ssh?

This was the error during bundle install:

In snapshot (Gemfile.lock):

net-ssh (2.1.4)

In Gemfile:

flying-sphinx (= 0.5.0) depends on
  net-ssh (~> 2.0.23)
  1. Support Staff 1 Posted by Pat Allan on 24 May, 2011 05:58 AM

    Pat Allan's Avatar

    I've just updated flying-sphinx to be a bit less fussy with regards to the net-ssh version - 2.0.23 or better. Are you using Rails 3? Just add the github source instead of the current gem release to your Gemfile, let me know how it goes.

  2. 2 Posted by Rob on 24 May, 2011 06:26 AM

    Rob's Avatar

    Worked like a charm, thanks Pat!

  3. Pat Allan closed this discussion on 24 May, 2011 06:29 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac