Heroku Gem Conflicts w/ Sorcery

tommyfeld's Avatar


28 Dec, 2011 09:19 PM

On heroku using cedar stack and Flying Sphinx:wooden.

Got a conflict:

Bundler could not find compatible versions for gem "faraday":
In Gemfile:

flying-sphinx (= 0.6.1) ruby depends on
  faraday (~> 0.7.3) ruby

sorcery (= 0.7.5) ruby depends on
  faraday (0.6.1)

Had to set flying sphinx 0.6.0. Will that affect heroku? About to try!


  1. 1 Posted by tommyfeld on 28 Dec, 2011 10:35 PM

    tommyfeld's Avatar

    It did affect heroku deploy. Had to roll back sorcery temporarily. Any insight would be helpful.

  2. Support Staff 2 Posted by Pat Allan on 28 Dec, 2011 11:32 PM

    Pat Allan's Avatar

    Hi Tommy

    When you're downgrading to flying-sphinx 0.6.0, you'll need to downgrade riddle and thinking-sphinx to 1.4.0 and 2.0.9 respectively - as flying-sphinx 0.6.1 and thinking-sphinx 2.0.10 require riddle 1.5.0, but earlier versions don't like that version of riddle.

    This also means that if you don't have riddle listed in your Gemfile, you should add it with an explicit version, to ensure you don't get stuck with v1.5.0 anyway. And if you're using Rails 2, then switch out TS 2.0.9 for 1.4.9.

    flying-sphinx 0.6.0 should still work fine, I'm fairly sure - let me know how you go.



Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac