Sphinx 2.1.X

Pedro Cunha's Avatar

Pedro Cunha

23 Jan, 2014 09:16 AM


Is there any timeline when sphinx 2.1.X will be available?

Thank you,

  1. Support Staff 1 Posted by Pat Allan on 23 Jan, 2014 09:38 AM

    Pat Allan's Avatar

    Hi Pedro

    Sphinx 2.1.4 is available on all Flying Sphinx servers (as is 2.0.9, for anyone wanting the latest of the 2.0.x releases). Just set version: 2.1.4 in your config/thinking_sphinx.yml file under the appropriate environments, and run the rebuild task.

  2. 2 Posted by Pedro Cunha on 23 Jan, 2014 09:45 AM

    Pedro Cunha's Avatar

    Hello Pat,

    I tried setting on config/sphinx.yml to 2.1.4 but it did not produce any effect - i validated this when i run fs:index it showed that was running 2.0.6. Is that supposed to be in config/thinking_sphinx.yml ? can you provide an example please?


  3. Support Staff 3 Posted by Pat Allan on 23 Jan, 2014 09:46 AM

    Pat Allan's Avatar

    Which version of Thinking Sphinx are you using?

  4. 4 Posted by Pedro Cunha on 23 Jan, 2014 09:51 AM

    Pedro Cunha's Avatar

    TS: 3.1
    FS: 1.0

    + Sinatra

  5. Support Staff 5 Posted by Pat Allan on 23 Jan, 2014 09:56 AM

    Pat Allan's Avatar

    Right - config/sphinx.yml is for v1/v2 of Thinking Sphinx, but config/thinking_sphinx.yml is for v3, so you definitely want to use that instead. So, in config/thinking_sphinx.yml, you'd put this along with any other settings you have in there:

      version: 2.1.4

    And then run a rebuild with this change deployed.

  6. 6 Posted by Pedro Cunha on 23 Jan, 2014 10:13 AM

    Pedro Cunha's Avatar

    Great. It does now work like a charm!

    Sorry might have missed the yml configuration part :/

    That was a quick support! Thanks

  7. Support Staff 7 Posted by Pat Allan on 23 Jan, 2014 10:15 AM

    Pat Allan's Avatar

    Great to know it's working :)

  8. Pat Allan closed this discussion on 23 Jan, 2014 10:15 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac