thinking-sphinx 2.0.2 requirement more visible

Eliot Walker's Avatar

Eliot Walker

16 Apr, 2011 06:31 PM

The links at the top of http://flying-sphinx.com/docs direct you to a "How to install Thinking Sphinx" page, which is very helpful. Unfortunately, the instructions there specify using Thinking Sphinx version 2.0.0 with Rails 3, which I followed.

After frustratingly dealing with an error "undefined method `generate' for #<ThinkingSphinx::Configuration:...> when attempting fs:index in heroku, I noticed the "You must use Thinking Sphinx 2.0.2 or later (for Rails 3), or 1.4.2 or later (for Rails 2). Older versions of Thinking Sphinx will not work with Flying Sphinx." instructions on the docs page.

If you could add a caveat next to the link at the top of the docs page like "This instruction set uses ThinkingSphinx 2.0.0, but make sure to use ThinkingSphinx 2.0.2" that would be much appreciated. In addition, my frustrating error could be added to some troubleshooting page with the solution of "Make sure you're using ThinkingSphinx 2.0.2."

Thanks!

  1. Support Staff 1 Posted by Pat Allan on 17 Apr, 2011 02:21 AM

    Pat Allan's Avatar

    Thanks for pointing that out Eliot - I've updated the TS docs to use the latest version numbers, as well as mentioning the version requirement beside the 'How to install Thinking Sphinx' link in the FS docs.

    Cheers

  2. Pat Allan closed this discussion on 17 Apr, 2011 02:21 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac